Loading...
 

media-alchemist package installation errors

Status
Open
Subject
media-alchemist package installation errors
Version
21.x
Category
  • Regression
  • Bug
Feature
Multimedia
Packages
Resolution status
New
Submitted by
Xavier de Pedro
Keep informed
Marc Laporte
Lastmod by
Xavier de Pedro
Rating
(0)
Description

I can't install media-alchemist due to several problems.. When attempted in 21.x through packages web control panel, this output is shown:

Problem 1
    - Conclusion: don't install media-alchemyst/media-alchemyst 0.5.5
    - Conclusion: remove monolog/monolog 2.0.2
    - Conclusion: don't install monolog/monolog 2.0.2
    - Installation request for media-alchemyst/media-alchemyst ^0.5.4 -> satisfiable by media-alchemyst/media-alchemyst[0.5.4, 0.5.5].
    - Conclusion: don't install monolog/monolog 2.0.2
    - media-alchemyst/media-alchemyst 0.5.4 requires monolog/monolog ~1.0 -> satisfiable by monolog/monolog[1.0.0, 1.1.0, 1.10.0, 1.11.0, 1.12.0, 1.13.0, 1.13.1, 1.14.0, 1.15.0, 1.16.0, 1.17.0, 1.17.1, 1.17.2, 1.18.0, 1.18.1, 1.18.2, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.22.1, 1.23.0, 1.24.0, 1.25.0, 1.25.1, 1.25.2, 1.25.3, 1.4.0, 1.4.1, 1.5.0, 1.6.0, 1.7.0, 1.8.0, 1.9.0, 1.9.1, 1.0.1, 1.0.2, 1.2.0, 1.2.1, 1.3.0, 1.3.1].
    - Can only install one of: monolog/monolog[1.17.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.17.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.17.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.18.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.18.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.18.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.19.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.20.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.21.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.22.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.22.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.23.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.24.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.3, 2.0.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.17.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.17.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.17.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.18.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.18.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.18.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.19.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.20.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.21.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.22.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.22.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.23.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.24.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.3].
    - Can only install one of: monolog/monolog[1.0.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.0.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.0.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.1.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.10.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.11.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.12.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.13.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.13.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.14.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.15.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.16.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.2.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.2.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.3.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.3.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.4.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.4.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.5.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.6.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.7.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.8.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.9.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.9.1, 2.0.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.0.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.1.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.10.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.11.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.12.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.13.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.13.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.14.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.15.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.16.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.4.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.4.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.5.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.6.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.7.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.8.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.9.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.9.1].
    - Installation request for monolog/monolog (locked at 2.0.2) -> satisfiable by monolog/monolog[2.0.2].


When attempted through the command line with this command,

php temp/composer.phar require --update-no-dev --prefer-dist media-alchemyst/media-alchemyst:^0.5.4


This is then the error message shown:

root@computer: /var/www/html/21.x# php temp/composer.phar require --update-no-dev --prefer-dist media-alchemyst/media-alchemyst:^0.5.4
Do not run Composer as root/super user! See https://getcomposer.org/root for details
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install media-alchemyst/media-alchemyst 0.5.5
    - Conclusion: remove monolog/monolog 2.0.2
    - Conclusion: don't install monolog/monolog 2.0.2
    - Installation request for media-alchemyst/media-alchemyst ^0.5.4 -> satisfiable by media-alchemyst/media-alchemyst[0.5.4, 0.5.5].
    - Conclusion: don't install monolog/monolog 2.0.2
    - media-alchemyst/media-alchemyst 0.5.4 requires monolog/monolog ~1.0 -> satisfiable by monolog/monolog[1.0.0, 1.1.0, 1.10.0, 1.11.0, 1.12.0, 1.13.0, 1.13.1, 1.14.0, 1.15.0, 1.16.0, 1.17.0, 1.17.1, 1.17.2, 1.18.0, 1.18.1, 1.18.2, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.22.1, 1.23.0, 1.24.0, 1.25.0, 1.25.1, 1.25.2, 1.25.3, 1.4.0, 1.4.1, 1.5.0, 1.6.0, 1.7.0, 1.8.0, 1.9.0, 1.9.1, 1.0.1, 1.0.2, 1.2.0, 1.2.1, 1.3.0, 1.3.1].
    - Can only install one of: monolog/monolog[1.17.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.17.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.17.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.18.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.18.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.18.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.19.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.20.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.21.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.22.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.22.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.23.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.24.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.25.3, 2.0.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.17.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.17.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.17.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.18.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.18.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.18.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.19.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.20.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.21.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.22.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.22.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.23.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.24.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.25.3].
    - Can only install one of: monolog/monolog[1.0.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.0.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.0.2, 2.0.2].
    - Can only install one of: monolog/monolog[1.1.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.10.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.11.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.12.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.13.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.13.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.14.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.15.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.16.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.2.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.2.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.3.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.3.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.4.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.4.1, 2.0.2].
    - Can only install one of: monolog/monolog[1.5.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.6.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.7.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.8.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.9.0, 2.0.2].
    - Can only install one of: monolog/monolog[1.9.1, 2.0.2].
    - Can only install one of: monolog/monolog[2.0.2, 1.0.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.1.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.10.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.11.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.12.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.13.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.13.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.14.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.15.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.16.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.4.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.4.1].
    - Can only install one of: monolog/monolog[2.0.2, 1.5.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.6.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.7.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.8.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.9.0].
    - Can only install one of: monolog/monolog[2.0.2, 1.9.1].
    - Installation request for monolog/monolog (locked at 2.0.2) -> satisfiable by monolog/monolog[2.0.2].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

Installation failed, reverting ./composer.json to its original content.
root@computer:/var/www/html/21.x# php temp/composer.phar require --update-no-dev --prefer-dist monolog/monolog:^1.0.0
Do not run Composer as root/super user! See https://getcomposer.org/root

I could solve by means of downgrading the monolog/monolog package to 1.x, and then reinstalling through command line worked.

root@computer:/var/www/html/21.x# php temp/composer.phar require --update-no-dev --prefer-dist monolog/monolog:^1.0.0
Do not run Composer as root/super user! See https://getcomposer.org/root for details
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies
Package operations: 22 installs, 1 update, 0 removals
  - Installing symfony/polyfill-ctype (v1.14.0): Loading from cache
  - Installing symfony/filesystem (v3.4.38): Downloading (100%)         
  - Installing symfony/polyfill-mbstring (v1.14.0): Loading from cache
  - Installing symfony/debug (v4.4.5): Downloading (100%)         
  - Installing symfony/console (v3.4.38): Downloading (100%)         
  - Installing pimple/pimple (v1.0.2): Downloading (100%)         
  - Downgrading monolog/monolog (2.0.2 => 1.25.3): Downloading (100%)         
  - Installing evenement/evenement (v1.1.0): Downloading (100%)         
  - Installing alchemy/binary-driver (1.6.0): Downloading (100%)         
  - Installing swftools/swftools (0.3.2): Downloading (100%)         
  - Installing php-unoconv/php-unoconv (0.3.1): Downloading (100%)         
  - Installing php-mp4box/php-mp4box (0.3.0): Downloading (100%)         
  - Installing neutron/temporary-filesystem (2.4): Downloading (100%)         
  - Installing doctrine/cache (1.10.0): Downloading (100%)         
  - Installing php-ffmpeg/php-ffmpeg (0.5.1): Downloading (100%)         
  - Installing imagine/imagine (v0.6.3): Downloading (100%)         
  - Installing symfony/http-foundation (v2.5.4): Downloading (100%)         
  - Installing doctrine/collections (1.6.4): Downloading (100%)         
  - Installing phpexiftool/exiftool (10.10): Downloading (100%)         
  - Installing alchemy/phpexiftool (0.7.2): Downloading (100%)         
  - Installing alchemy/mediavorus (0.4.10): Downloading (100%)         
  - Installing alchemy/ghostscript (0.4.0): Downloading (100%)         
  - Installing media-alchemyst/media-alchemyst (0.5.5): Downloading (100%)         
Package robloach/component-installer is abandoned, you should avoid using it. Use oomphinc/composer-installers-extender instead.
Writing lock file
Generating autoload files
> ComponentInstaller\Installer::postAutoloadDump
Compiling component files
root@computer:/var/www/html/21.x# php temp/composer.phar require --update-no-dev --prefer-dist media-alchemyst/media-alchemyst:^0.5.4
Do not run Composer as root/super user! See https://getcomposer.org/root for details
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies
Nothing to install or update
Package robloach/component-installer is abandoned, you should avoid using it. Use oomphinc/composer-installers-extender instead.
Generating autoload files
> ComponentInstaller\Installer::postAutoloadDump
Compiling component files
root@computer:/var/www/html/21.x#
Importance
4
Easy to solve?
9
Priority
36
Demonstrate Bug
Please demonstrate your bug on show2.tikiwiki.org
 About show2.tikiwiki.org

To help developers solve the bug, we kindly request that you demonstrate your bug on a show2.tikiwiki.org instance. To start, simply select a version and click on "Create show2.tikiwiki.org instance". Once the instance is ready (in a minute or two), as indicated in the status window below, you can then access that instance, login (the initial admin username/password is "admin") and configure the Tiki to demonstrate your bug. Priority will be given to bugs that have been demonstrated on show2.tikiwiki.org.

Version: Create show2.tikiwiki.org instance
Ticket ID
7303
Created
Tuesday 03 March, 2020 22:54:12 GMT-0000
LastModif
Tuesday 03 March, 2020 22:54:12 GMT-0000

Attachments

 filenamecreatedhitscommentversionfiletype 
No attachments for this item


Keywords

The following is a list of keywords that should serve as hubs for navigation within the Tiki development and should correspond to documentation keywords.

Each feature in Tiki has a wiki page which regroups all the bugs, requests for enhancements, etc. It is somewhat a form of wiki-based project management. You can also express your interest in a feature by adding it to your profile. You can also try out the Dynamic filter.

Accessibility (WAI & 508)
Accounting
Administration
Ajax
Articles & Submissions
Backlinks
Banner
Batch
BigBlueButton audio/video/chat/screensharing
Blog
Bookmark
Browser Compatibility
Calendar
Category
Chat
Comment
Communication Center
Consistency
Contacts Address book
Contact us
Content template
Contribution
Cookie
Copyright
Credits
Custom Home (and Group Home Page)
Database MySQL - MyISAM
Database MySQL - InnoDB
Date and Time
Debugger Console
Diagram
Directory (of hyperlinks)
Documentation link from Tiki to doc.tiki.org (Help System)
Docs
DogFood
Draw -superseded by Diagram
Dynamic Content
Preferences
Dynamic Variable
External Authentication
FAQ
Featured links
Feeds (RSS)
File Gallery
Forum
Friendship Network (Community)
Gantt
Group
Groupmail
Help
History
Hotword
HTML Page
i18n (Multilingual, l10n, Babelfish)
Image Gallery
Import-Export
Install
Integrator
Interoperability
Inter-User Messages
InterTiki
jQuery
Kaltura video management
Karma
Live Support
Logs (system & action)
Lost edit protection
Mail-in
Map
Menu
Meta Tag
Missing features
Visual Mapping
Mobile
Mods
Modules
MultiTiki
MyTiki
Newsletter
Notepad
OS independence (Non-Linux, Windows/IIS, Mac, BSD)
Organic Groups (Self-managed Teams)
Packages
Payment
PDF
Performance Speed / Load / Compression / Cache
Permission
Poll
Profiles
Quiz
Rating
Realname
Report
Revision Approval
Scheduler
Score
Search engine optimization (SEO)
Search
Security
Semantic links
Share
Shopping Cart
Shoutbox
Site Identity
Slideshow
Smarty Template
Social Networking
Spam protection (Anti-bot CATPCHA)
Spellcheck
Spreadsheet
Staging and Approval
Stats
Survey
Syntax Highlighter (Codemirror)
Tablesorter
Tags
Task
Tell a Friend
Terms and Conditions
Theme
TikiTests
Timesheet
Token Access
Toolbar (Quicktags)
Tours
Trackers
TRIM
User Administration
User Files
User Menu
Watch
Webmail and Groupmail
WebServices
Wiki History, page rename, etc
Wiki plugins extends basic syntax
Wiki syntax text area, parser, etc
Wiki structure (book and table of content)
Workspace and perspectives
WYSIWTSN
WYSIWYCA
WYSIWYG
XMLRPC
XMPP




Useful Tools