Loading...
 

Category: Closed - Duplicate

The ticket is a duplicate, must reference the the other ticket
Closed - Duplicate
Show subcategories objects

Name Type
12.x: can't post comments if codemirror is on (it says 'Content is empty')
tracker item
13.x regression: rating_smiley icons in reversed order
tracker item
13.x regression: rating_smiley icons in reversed order
tracker item
5.0RC1 - wiki Editing option "check orthography" ->em error : table "babl_words_fr" missing
Hello,

After a cut off of adsl line during 3 weeks because of a sinister, I come back (but the speed remain the slowest 300kb/s).
hello,

When you set the option check-orthography (french language), when you try to save you get the SYSTEM ERROR :


La table 'teawik-ld8-50s-new1.babl_words_fr' n'existe pas

__The table '<database_name>.babl_words_fr' don't exist__

The query was :
select `word` from `babl_words_fr` where `word`=? or `word`=?

Valeurs :

1. Table
2. table

The built query was likely :
select `word` from `babl_words_fr` where `word`='Table' or `word`='table'

Stacktrace :
* <site_dir>\tiki-editpage.php : 0 -> {main}(array ( ))
* <site_dir>\tiki-editpage.php : 853 -> spellcheckreplace(array ( ))
* <site_dir>\lib\tikilib.php : 1659 -> spellcheckword(array ( ))
* <site_dir>\lib\tikilib.php : 1704 -> spellcheck_word(array ( ))
* <site_dir>\lib\bablotron.php : 44 -> word_exists(array ( ))
* <site_dir>\lib\bablotron.php : 104 -> query(array ( ))
* <site_dir>\lib\core\lib\TikiDb\Bridge.php : 29 -> query(array ( ))
* <site_dir>\lib\core\lib\TikiDb\Pdo.php : 119 -> handleQueryError(array ( ))
* <site_dir>\lib\core\lib\TikiDb.php : 150 -> handle(array ( ))
tracker item
Automatically fill in Page Name field when creating new links fck
Some users don't want to understand the difference between "Page Name" and Link when creating an internal link.

This attached patch makes the Page Name field automatically fill in whenever the Link field is changed. The patch was made against tw 4.1.

I think it should be up for debate if both these fields are necessary. Many users of the WYSIWYG feature may be new to the concept of creating links. Less is simpler, and I vote for removing one of these fields.

P.S. Sorry about spamming the mailinglist with this request. Next time I will only submit patch here.
tracker item
Automatically fill in Page Name field when creating new links fck
Some users don't want to understand the difference between "Page Name" and Link when creating an internal link.

This attached patch makes the Page Name field automatically fill in whenever the Link field is changed. The patch was made against tw 4.1.

I think it should be up for debate if both these fields are necessary. Many users of the WYSIWYG feature may be new to the concept of creating links. Less is simpler, and I vote for removing one of these fields.

P.S. Sorry about spamming the mailinglist with this request. Next time I will only submit patch here.
tracker item
Blue Print CSS / BluePrintCSS
CSS... Themes...
tracker item
Button links broken on IIS installation
I have installed TikiWiki 3rc1 on an IIS (Windows Server 2003) installation with PHP 5 and MySQL. This is a root-level installation. For some reason having to change PATH_TRANSLATED to SCRIPT_FILENAME in line 31 of lib/setup/tikisetup.class.php, which if I don't do I get errors relating to directories not existing and the site not loading at all; this is not the purpose of the support request.

Once I make these tweaks, as well as after setting the tweaks identified in tiki-filter-base.php (that is, changing forward slashes to double-backslashes in quotes), I get the site up and running. ***But*** on administration pages, the buttons created by lib/smarty_tiki/function.button.php (such as "CLEAR CACHE" on the Modules admin page) don't seem to work when accessing the site from Safari or Firefox (Internet Explorer works fine for this).

Instead, in Safari, the clicking on the button will load the script name where the domain name is supposed to go; if my site was on http://site.com/somescript.php?something, it would load http://otherscript.php?something. I don't have my machine handy, so I can't get the Firefox results up at the moment, but IIRC they involved the format http://site.com/\/otherscript.php?something (with a backslash and forward-slash inserted).

A Linux installation of TW3 works fine in Safari and Firefox, so my guess is that it's an IIS issue that has something to do with backslashes and root-directory determination, but I'm somewhat clueless here. I've examined lib/smarty_tiki/block.self_link.php and some tweaking there has produced no viable results.

Also note that this goes away when TikiWiki 3 is placed into a non-root directory; it only affects a root installation at /, rather than at a server subdirectory.
tracker item
Cannot change an Article's language from its Translate page
The "Change language for this page" form fails when it's applied to an Article.
tracker item
Cannot modify user password
I installed Tiki 5.3 from Fantastico and then ran the setup script.

I was able to create some new users and assign them to groups.

The problems manifested when I attempted to change the default admin password and the password that I forgot for one of the new users.

Upon clicking "Edit Account Settings" next to the user, tiki-adminusers.php is displayed with the user number (e.g. tiki-adminusers.php?user=3).

There are three buttons, clicking the one to "confirm" the action causes tiki-adminusers to display a form for editing the password, email, etc. for the user.

"Saving Changes" causes tiki-admin users to again present the three buttons, this time without any user number on the URL.

Clicking to "Confirm" adds a "#" sign to the end of the URL, but nothing seems to happen.

The original password is unchanged and other values entered on the form are unchanged.
tracker item
Contact Us feature strips email address
The email sent to the admin with the form that was filled by an anonymous user, it shows the email address of the user but only the part that is before de "@" sign.



Using
Tiki 6.1 fresh code install, on past 6.0 db updated to 6.1.

tracker item
Custom Search on a simple tracker doesn't work for me with the basic example in doc.t.o
tracker item
End of Installation Pressing Continue to Site Produces "Tiki is not properly set up:" message
Hi,

I installed Tiki v4.2 on a Windows host. The installation appeared to go cleanly to the end with no issues. I selected the first continue button to website locking the installer and received an error message.

I am replacing the real folders with abbreviated ones for security and readability sake.

-------
Tiki is not properly set up:

The directory 'e:\a\b\c\d\e/dump/' does not exist.
The directory 'e:\a\b\c\d\e/img/wiki/' does not exist.
The directory 'e:\a\b\c\d\e/img/wiki_up/' does not exist.
The directory 'e:\a\b\c\d\e/modules/cache/' does not exist.
The directory 'e:\a\b\c\d\e/temp/' does not exist.
The directory 'e:\a\b\c\d\e/templates_c/' does not exist.
-------

My comment is of course the above will produce an error. TikiWiki should have never, even on its own made e:\a\b\c\d\e as a base of the site/tiki folder. The base should be:

e:\a\b\c\d\e\Wiki\tiki

The subdomain / domain points to:

e:\a\b\c\d\e\Wiki

I installed tiki naturally into a /tiki sub-folder. I ran the installer as

http://<mysubdomain>/tiki/tiki-installer.php (or whatever the file name is)

Going manually to the index page produces the same error screen.

How do I fix the bug?

Thanks in advance.
tracker item
After Upgrading 6.3 -> 8.0rc1 split shows ~lt~br /~gt~ instead of linebreaks
I updated a copy of our wiki to 8.0rc1 to have a look whats new and just wanted to tell you the first problem i immediately saw:

but the first thing i saw was that all line breaks in the heavily used split-plugin were actually displayed as ~lt~br /~gt~ instead of being actual line breaks
tracker item
last forum post module does not display posts
The last forum post module will not display any post unless you are logged in as admin.
tracker item
LDAP Auth bug
Fatal error when trying to authenticate against an LDAP server on IIS6 Windowns 2003 Server:

Fatal error: Call to undefined method Net_LDAP2_Error::getEntry() in D:\WWWROOT\wiki60\lib\auth\ldap.php on line 257
tracker item
Per user/group newsletter administration (adding category or object permissions)
tracker item
Random poll {poll} not working
Tiki should be able to insert a random, active poll by using:
{CODE()}
{poll}
{CODE}

However, this is broken in 7.x and 6.3
tracker item
Tracker Admin – Import/Export titled Duplicate
3.1 on Linux, Apache, PHP5
*created tracker
*duplicated that tracker
Since then if I'm in tracker admin (tiki-admin_trackers.php) the third tab
says “Duplicate Tracker”. Clicking on it, it will load the
“Import/Export” page though.
Going into a trackers details there are 4 tabs again, and those have
correct names / load the correct pages.
tracker item
Unable to submit new password for user in user admin
When trying to reset a password for a user you can't click the confirm button on the confirm page. Click the confirm to submit the form gives the javascript error "uncaught TypeError: Property 'submit' of object #<an HTMLFormElement> is not a function" in chrome. This is caused by one of the inputs in the form being named submit. So the function the confirm button calls "javascript:document.forms['confirm'].submit();" is calling the submit input element instead of the submit method of the form. To fix this change the name of the submit button in tiki-adminusers.tpl from "submit" to something else.
tracker item
Watches appear in foreign languages
When you are watching an item, the email is sent in the language of the site visitor, not your own chosen language.
tracker item
Wrong path with additional slash on IIS installs in document root
Environment: Windows Server 2008 + IIS7

Problem: After installation, you're directed to tiki-change_password.php. The URL ist correct (in my case: "http://www.prohibition-online.com/tiki-change_password.php[...]"). I change the password and land on "http://www.prohibition-online.com/tiki-index.php".

Now I click onto logout and the URL I get to is:
"http://www.prohibition-online.com\/tiki-index.php".

Notice the "\" after my website name.

If I remove the "\", I access my index page as expected.

When I login, the "\" reappears.

same error as: http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=2250&trackerId=5&show=view
tracker item
WYSIWYG editor addes extra <br> tags
When one is using the WYSIWYG editor to edit text, extra <br /> tags are added after all <p> and <br /> tags when the text is displayed after save or preview. These tags don't show up in the source code in the WYSIWYG editor at all, so you can't remove them. As a result, the spacing between the text is all wrong.

For example, if you view the source of a page in the WYSIWYG editor, it would look like this:

<p>Some text<br />And more text on a new line</p>

But when you view the source of the page after you have saved it, it looks like this:

<p>Some text<br /><br />And more text on a new line</p><br />

tracker item
WYSIWYG Insert internal link fails
ON aVersion 2.2 installation on a Windows server.

When I use the WYSIWYG editor and select the insert internal link icon, the window appears titled "Tiki Link - insert internal link" and the squares indicating loading are blinking, but it hangs (and does not bring up the list of links).
tracker item

Keywords

The following is a list of keywords that should serve as hubs for navigation within the Tiki development and should correspond to documentation keywords.

Each feature in Tiki has a wiki page which regroups all the bugs, requests for enhancements, etc. It is somewhat a form of wiki-based project management. You can also express your interest in a feature by adding it to your profile. You can also try out the Dynamic filter.

Accessibility (WAI & 508)
Accounting
Administration
Ajax
Articles & Submissions
Backlinks
Banner
Batch
BigBlueButton audio/video/chat/screensharing
Blog
Bookmark
Browser Compatibility
Calendar
Category
Chat
Comment
Communication Center
Consistency
Contacts Address book
Contact us
Content template
Contribution
Cookie
Copyright
Credits
Custom Home (and Group Home Page)
Database MySQL - MyISAM
Database MySQL - InnoDB
Date and Time
Debugger Console
Directory (of hyperlinks)
Documentation link from Tiki to doc.tiki.org (Help System)
Docs
DogFood
Draw
Dynamic Content
Preferences
Dynamic Variable
External Authentication
FAQ
Featured links
Feeds (RSS)
File Gallery
Forum
Friendship Network (Community)
Group
Help
History
Hotword
HTML Page
i18n (Multilingual, l10n, Babelfish)
Image Gallery
Import-Export
Install
Integrator
Interoperability
Inter-User Messages
InterTiki
jQuery
Kaltura video management
Karma
Live Support
Logs (system & action)
Lost edit protection
Mail-in
Map
Menu
Meta Tag
Missing features
Visual Mapping
Mobile
Mods
Modules
MultiTiki
MyTiki
Newsletter
Notepad
OS independence (Non-Linux, Windows/IIS, Mac, BSD)
Organic Groups (Self-managed Teams)
Packages
Payment
PDF
Performance Speed / Load / Compression / Cache
Permission
Poll
Profiles
Quiz
Rating
Realname
Report
Revision Approval
Scheduler
Score
Search engine optimization (SEO)
Search
Security
Semantic links
Share
Shopping Cart
Shoutbox
Site Identity
Slideshow
Smarty Template
Social Networking
Spam protection (Anti-bot CATPCHA)
Spellcheck
Spreadsheet
Staging and Approval
Stats
Survey
Syntax Highlighter (Codemirror)
Tablesorter
Tags
Task
Tell a Friend, alert + Social Bookmarking
Terms and Conditions
Theme
TikiTests
Timesheet
Token Access
Toolbar (Quicktags)
Tours
Trackers
TRIM
User Administration
User Files
User Menu
Watch
Webmail and Groupmail
WebServices
Wiki History, page rename, etc
Wiki plugins extends basic syntax
Wiki syntax text area, parser, etc
Wiki structure (book and table of content)
Workspace and perspectives
WYSIWTSN
WYSIWYCA
WYSIWYG
XMLRPC
XMPP




Useful Tools