Loading...
 

Category: Open - Confirmed

The ticket has been reviewed and confirmed
Open - Confirmed
Show subcategories objects

Name Type
"GZip output" (feature_obzip) causes encoding errors in CSRF and error screens
"Gzip output" (feature_obzip) is defective in two different tikis (in 2 different servers).... proposals/6x and trunk

Once enabled, when I attempt to visit a few pages as anonymous, for which I should see the "Error, your are not logged in. Go to Log in Page" message, I see instead a message from firefox saying that there is an error in the enconding of the content (attempting to use a compression method not valid or that it doesn't work in this application):

{QUOTE()}
Error de codificació del contingut

No ha pogut mostrar-se la pàgina que esteu intentant visualitzar perquè utilitza una forma de compressió no vàlida o que no funciona en aquesta aplicació.

* Poseu-vos en contacte amb els propietaris del lloc per a informar-los del problema.
{QUOTE}

Once I disable the gzip output, tiki behaves normally.
---
Moreover, this issue might have been the reason why the new spreadsheet features being developed in trunk by robertplummer were failing (Chrome just says that the server is temporarily unavailable) recently in a test we were doing in the same server.

And that might be the (potential) responsible for the issues with sending newsletters in prposals/6x (just before the release of tiki 6.2).
tracker item
12.x & 13.x: Images stretched & skewed (in *.t.o sites and LTS production sites on svn)
tracker item
Rating Tracker Bugs - with field type 'Stars (system)'
If I add a rating to a new tracker, the rating is not saved.

Also the rating value star has an opaque white background.

These occur on dev.tiki.org presently.

~~#F00:Update:~~ Still not working on dev.tiki.org revision 48335. {sign user="Bsfez" datetime="2013-11-05T07:14:49+00:00"}

The rating gets saved now but is not displaying. {sign user="pascalstjean" datetime="2013-11-24T00:42:50+00:00"}

~~#F00:Update : ~~ I retested on the 28/11/13. {sign user="Bsfez" datetime="2013-11-28T13:22:50+00:00"}
Not logged i saw that they were 3 votes but could see star on or off;
{img fileId="645" thumb="y" rel="box[g]"}

Once logged i voted and the score was reseted to 0;
{img fileId="646" thumb="y" rel="box[g]"}
---
This worked well in Tiki9., and it's still borken as of r49090 (December 15th). {sign user="xavi" datetime="2013-12-15T10:27:49+00:00"}
If Rating with "Stars (system)" is supposed to be deprecated, could someone please help to switch the rating system in the dev.t.o Bug Tracker ([tracker5]) so that it can use whatever new rating system is not "deprecated"?
This way, since the new [http://doc.tiki.org/Rating%20Tracker%20Field|Rating field is not documented] as of Dec 14th 2013, we could see it here at least as a working example.{sign user="xavi" datetime="2013-12-15T10:39:46+00:00"}
---
Ok, added the new Rating system myself to the Bug Tracker (new field 152: "New Rating"). And it works out of the box. Good job whoever coded the new feature. {sign user="xavi" datetime="2013-12-15T10:45:10+00:00"}
tracker item
domain redirect from *.tikiwiki.org to *.tiki.org is not working
tracker item
Adding many users to a group with Chosen fails.
tracker item
Banning system Rule activated by dates lacks following years
Rule activated by dates
Rule active from
Rule active until
Upgraded tiki: Shows years 1969 till 2010
Clean install: Only gives the year 2010 to chose from
This year is almost over so whould be nice to have some later years to chose from.
tracker item
Big avatar in forums, elsewhere
"If a user upload a big avatar (more than 45x45 px) tiki 2.1 not 'avatarize' and show the big image in the forums. This problem may be very uncomfortable when you read a forum topic."

I can confirm that this still occurs on tiki.org and whatever Tiki version it is running presently, specifically with GIF images. -- ssanders
tracker item
Blacklist domains and words
Discussion over at ((Spam Protection))

http://www.wikimatrix.org/wiki/feature:Blacklist
tracker item
Blog publish date not recognized by last_blog_posts module
When you publish a blog post using an upcoming publish date, post appears right away in last_blog_posts module even if the publish date is stll in the future.
tracker item
Bug in Tiki14Beta? Copy Forum doesn't work
tracker item
Calendar Popup CSS errors
__Calendar Popup Misplaced__

5.0 RC1 r27394, still applies in trunk r28611.

CSS errors in the popups in weekly and daily view.
*first time an item is clicked, the popup shoots to the top of the page
*2nd and subsequent times it appears in a reasonable place
*produces a question-mark mouse pointer
*apparently independent of theme
*Monthly view behaves ok and no "?" pointer
tracker item
Can't delete an item from a Structure directly after adding it
tracker item
Cannot connect to profile repos after svn update
After SVN update, the connection to the profiles repo is not possible (the icon is yellow). Setting write perms to all files/folders seem to solve the problem but probably it is only some folder of which perms are changed and need setting. To investigate what exactly is the issue and provide a better error message than simply yellow icon.
tracker item
Change a tracker item status to closed after a specified date
Our org is trying to create a tracker for short term employment vacancies. In the tracker we have a date field called "deadline" where we want an applicant to respond to the vacancy before that date. What we would like is for the vacancy (tracker item) to change status to "close" after that date automatically.

I have found in [http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=1694] that [http://dev.tikiwiki.org/tiki-user_information.php?userId=21|sylvie] made a comment:
""
- must be finished before can be a date field. what happens to the item after? (I have on my list 'an item change status after n days')
which sounds roughly the same as what I am trying to accomplish.
""
Can someone elaborate or let me know if it is possible to automate the closing of items?

Thanks,
Tim
tracker item
CODE Plugin "eats" code, especially HTML
tracker item
Creating user needs confirm, and if password not match back does not work
Try creating a new user in tiki-admin_users.php.

Whether the password don't match or not you are asked to confirm the action. Is this really needed? Anyway if the passwords don't match you get an error after confirming the action and then the "Go Back" does not work... it is very troublesome.
tracker item
Duplicate notifications sent when group and user watches set on same page
If a user Alain sets a watch on a page, and there is already a group watch on that page for a group to which he belongs, then Alain gets two notifications whenever the page is changed.

This was found on terminology.tikiwiki.org which runs 4.x
tracker item
Dynamic item list select gadget is too narrow
tracker item
Editing a comment for a trackeritem does not update the comment using codemirror
tracker item
External feeds do not update without dom extension
This may be 2 bugs:

When you select Admin - External feeds and create a new feed, a blank page is presented after clicking "Save." It appears as though the external feed is saved, though.

Created feeds are not being updated on a schedule, nor are they being updated when the "Refresh" option is clicked. Clicking "Refresh" results in a blank page being displayed.

This has been ((http://tikiwiki.org/tiki-view_forum_thread.php?comments_parentId=37418&topics_offset=23&topics_sort_mode=lastPost_desc&forumId=4|reported on the forum.))
tracker item
ImgPlugin does not respect alignment after mouseover / mousesticky
tracker item
improvements to the printing process of a full structure like the one in doc.tw.o/Documentation
^ Related to http://dev.tikiwiki.org/bug1184 . Opened a new one since those comments below are updated of a new trial I made today - Jan. 7th, 2009^
Issues detected while dogfooding "__minimum-clicks for pdf from doc.tw.o/Documentation structure__". An opportunity to improve the current features for production.
Related links:
http://doc.tikiwiki.org/Documentation
and
http://doc.tikiwiki.org/tiki-print_pages.php

Printed to html using SeaMonkey browser 1.1.12 and to pdf CUPS/pdf printer, both under Ubuntu 8.04 GNU/Linux
page numbers refer to a pdf produced today out of there:
[ftp://ftp.ourproject.org/pub/edutiki/090107_doc_tw_o___Tikiwiki_Documentation_SeaMonkey.pdf]
(25Mb)
-----------------------------------------------------------------------------

* Autonumbering of headings is shown on the table of contents, but not on the pages themselves (using the default theme in doc.tw.o, based on thenews.css I guess). I would say that this worked for me a month ago on a 2.1 site using feb12.css with another (shorter) structure of wiki pages ( http://www.iesbarcelona.org/ESSO350/tikiwiki-2.1/tiki-index.php?page=2008+Fall+-+Final+Paper ).

* page 39: .htaccess from dynamic content is not shown in the full page. Can this be modified at printing time so that the full content is shown on the page?

* page 41: a CODE block longer than a single sheet of paper is cut at the end of the page, not showing the rest of the content. Can this be modified at printing time so that the full content is shown on the page?

* Some pages didn't have the title manually displayed. Those ones doesn't show the title of the page (as section of the full pdf)... Maybe the best workaround is to add a setting for the user to select whether he/she wants adding all page names as titles to the pages, or not. For our case, maybe it's easier to remove extra title (easy to identify when you have too title too similar one after the other) than having to figure out where a new page starts... (see plugins pages...). Example: page 127: PluginJS is shown, fine, but not PluginLang, PluginListpages? Plugin Manager?, on the following pages...

* copyright license is needed at the end?

* It would be nice to allow at structure-printing time to select which version among the ones allowed by the PLUGIN VERSIONS (where applicable), had to be selected for printing. Right now, it might be useful for people looking for an updated documentation for their 1.9.x, so that all plugin versions were pre-set to display the content from 1.9.x. Moreover, after April (only some months to go for that) we will have the same issue with people looking for 3.x documentation, or just 2.x. Well, this is just to raise this point for the following months, so that, the better for us for producing our own documentation, the better for other communities producing their documentation using Tiki and coping with their versions also... (Firefox, for instance?)

* when the content is copied and pasted to OpenOffice (using OOo 2.x and 3.x), there are images or tables which are wider than the page size.

* Is it possible to have page breaks added before headings of level X (and let the user select a page break just before a heading level 1, and 2, for instance).
---
Update on Dec 7th, 2012 (Tiki9.x LTS):
* RFE still valid....
tracker item
Big avatar in forums, elsewhere
"If a user upload a big avatar (more than 45x45 px) tiki 2.1 not 'avatarize' and show the big image in the forums. This problem may be very uncomfortable when you read a forum topic."

I can confirm that this still occurs on tiki.org and whatever Tiki version it is running presently, specifically with GIF images. -- ssanders
tracker item
File is not an image
Hello,

i've upgrade my site at 8 version.

now when i upload an image and i try to use with img placeholder appear the error "file is not an image"

i read that is couse by Ajax uploader, indeed i've activated this feature recently.
so i 've unactiveted this feature but the uploader is still in Ajax.

can anybody help me?
tracker item
Zend_Search_Lucene doesn't work on certain servers
To reproduce, search "wiki" in the admin panel here:
http://branding.tiki.org/tiki-admin.php

And you will get:
"No preferences were found for your search query."

Ideally, the problem is solved, but this is maybe tricky. It could be related to:

{QUOTE(replyto="http://framework.zend.com/manual/1.11/en/zend.search.lucene.index-creation.html")}"Zend_Search_Lucene uses flock() to provide concurrent searching, index updating and optimization. According to the PHP » documentation, "flock() will not work on NFS and many other networked file systems. Do not use networked file systems with Zend_Search_Lucene."{QUOTE}

At the very least, Tiki should detect and report to the site admin that he should use MySQL Full Text Search instead.

Ideally, MySQL Full Text Search would work for tiki-admin.php
tracker item
9.x svn to 10.x svn: files don't get uploaded to file galleries
I confirm that I saw this serious issue in a production site of myself using tiki 10.x (svn r44603). This site of mine was upgraded in early january from tiki 9.x svn to 10.x svn. And nowadays when uploading some jpg images, they are not displayed, the image name seems to be truncated the extension (foo.jpg is converted into foo, it seems). And the error message in my case indicates a valid path (as it was working fine for a year in the server, etc.; no changes on that side; I doubled checked and perms are fine for apache to write in those folders, etc).

The hash corresponding to the file (as indicated in the error message shown in the browser) does not exist in the server, so it seems that the file does not get uploaded to that folder.

I can provide more details (or even maybe access to my production server) to some dev willing to debug this issue.

---

I started to see report in the user forums in t.o about (potentially) similar issues. Example:
https://tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=45767&thread_sort_mode=commentDate_asc#comments
tracker item
9x: Search box in Relations tracker field doesn't find items with apostrophe in name
We have a couple of tracker field type "relations" in a tracker, showing other items from the same tracker, and it displays a search box at the left of the dropdown box.
when we filter for item which have an apostrophe (single quote: '), the filter doesn't seem to find them. Without apostrophe, it does.
I.e., imagine that we have these two items (without the star):

* foo bar
* foo bar'2 foo bar foo bar

if we search for "foo", we find just the first one, not the second.

Apostrophes are very common in Catalan, as they are in French and other languages (in English it can be tested against items with names such as this onem, which has the word "doesn't" in purpose ;-).
tracker item
login to tv.tiki.org broken (issue with PluginSlider?)
tracker item
Make RSS feeds page look nicer
Please see:
http://themes.tikiwiki.org/tiki-forums_rss.php?ver=2

The logo should be the site logo, if available.
Make sure of i18n
Make more generic. ie : no "Tiki RSS feed for forums". It should be just RSS for forums.

Test in various browsers. Especially IE6, IE7, and FF2
tracker item
Menu parameter combination causes bad configuration
tracker item
Mixup between word and character limits in textarea tracker field
When I put a textarea field in a tracker, in the edition item mode the caracters and words limit they're mixed up.

This was reproduced on the r27905 on trunk


For example, if the word limit is set to 3 and the caracter limit is set to 30, is possible to enter text as long as limit are respected but the counts bellow are wrong. The word count shows in the field for the caracters count. And the caracters count is not displayed.

See the next screenshot to understand more
{IMG(src="http://dev.tikiwiki.org/tiki-download_item_attachment.php?attId=256")}{IMG}
tracker item
No email notification when table changed or watch ability
I can not find the ability to receive an email notification when a table gets changed.

It would be very useful if this capability were part of tikiSheets. Several other tikiwiki features have this feature through the watch capability.
tracker item
Notifications should parse the body
In general, wiki syntax is not parsed in notification mails. For example, the "New article post" notification email includes the full body of the newly posted article. However, Tiki includes the full wiki coding/syntax within the body of the message, and sends the mail message as plain text. Tiki should either:

1. Send the message as parsed HTML

or

2. Strip all formatting and send only the text.
tracker item
Quiz results doesn't work
I have made a Quiz on my Tiki site and it is working, but when you take the Quiz, it goes to the results page and shows nothing. I am running Tiki 4.1. It always shows the word Results with a line and nothing else, although a result value is set for every option.
tracker item
Rebuild Unified Search Index failed: Identifier name too long
tracker item
The second editor of a page in wysiwyg mode will see an empty editor bloc when overriding
tracker item
With URL rewriting enabled, attempt to access invalid URL yields strange techie error message rather than usual "page not found"
tracker item
Update Tiki importer to support current MediaWiki XML spec
tracker item
Update to Tiki >= 5.3 fails on Windows ("Cannot execute queries while other unbuffered queries are active")
On updating Tiki 5.2 and earlier to 6 errors occur during installation.

^Cannot execute queries while other unbuffered queries are active. Consider using PDOStatement
fetchAll(). Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO MYSQL_ATTR_USE_BUFFERED_QUERY attribute.^

The problem is discussed [http://tiki.org/tiki-view_forum_thread.php?comments_parentId=39458&topics_offset=5&topics_sort_mode=lastPost_desc&forumId=6|over here]

--
Chealer:
This does not happen upgrading from a clean install of 5.3 to 6.0. But it happens when upgrading from 5.0 to 6.0. The most problematic script appears to be 20100927_better_column_fix_tiki. The first query (getOne() on information_schema) seems to be the sticky unbuffered query sometimes, since the following, second query fails. I tried but couldn't find how to confirm what query is stuck. It's odd that this problem only happens in the installer. getOne() just like query() use fetchAll() so we shouldn't see this problem. Setting MYSQL_ATTR_USE_BUFFERED_QUERY doesn't seem to help. After some 10 hours of debugging I'm under the impression this is a PDO bug. This looks like http://bugs.php.net/bug.php?id=44081 If anyone wants to try fixing, I recommend speaking to me first. The PDO documentation is very poor, making this really difficult.
20100927_better_column_fix_tiki was introduced in 5.3.

I found upgrades would work with PDO in certain environments. I had the bug on PHP 5.2.13 but upgrading to 5.3.3 fixed. PHP 5.3 can use mysqlnd, which I suspect doesn't have this problem. The upgrade worked for me on vanilla PHP 5.3.3 or PHP 5.3.3 from EasyPHP, both with mysqlnd. I have no clue why this problem seems to only affect Windows, but I saw reports of similar problems on Debian etch, so it may not be completely Windows-specific. Anyone who experiences this problem, please report your PHP version, and if you use PHP 5.3, indicate whether you use libmysql or mysqlnd.
tracker item
TrackerCalendar doesn show items with any Uppercase in resource tracker field (Was: Usability fixes for Plugin TrackerCalendar (FullCalendarResourceViews) )
tracker item
wiki help - plugin list sorting
The plugin section of the wiki help is listing the plugins aplhabetically based on their english name. When it is translated to another language the sorting remains based on the english name, it is quite confusing and looks a bit chaotic in other languages in my opinion. Is there a specific reason why the code here is written this way? If not, can this be fixed for Tiki 4? I dont know how to do it but would appreciate it :)
tracker item
Wiki page print function can preview unapproved page
tracker item
Wysiwig FCKEditor on test : the background of long text area when vertical scroll is black - Firefo
This seems solved in Tiki 5.

''type content'' : Problem, way to go around and may be a quick way to go to a solution

Hy,
4.0, 4.1

I test all functions including those that are not finalized.

The problems occurs with Firefox 3.5 not with IE8 (other ie not tested neither opera, google etc...)

In WISIWIG text editing WIKI obtained in circumstances that I can not confirm the background color of textarea is black when you scroll to the end of long text (the text is more long than the height of textarea).
The content text exist and you can see it if you select it and change the text background color.
The problem is the scroll with the background property color (in strasa css #F3FCFE color)

''Complements''
*Problems occurs in wysiwyg mode (not in view source mode)
*If you change the background color of the text you can see it
*The problem is directly linked to scroll, when you change the textarea size (for example go to "fullscreen" edit), the black background appears at the bottom just one line after beginning to scroll down



I hope to have provided informations to go straight to the bug.

Best regards
tracker item
WYSIWYG Editor Transparent background Issue
The WYSIWYG editor has a transparent background that seems to be hard-coded and unaddressable by css. It appears in an iFrame so the page's body background colour is seen in the textarea.

This makes it unusable for themes with dark backgrounds like Strasa as you have basically black-on black text.
tracker item

Keywords

The following is a list of keywords that should serve as hubs for navigation within the Tiki development and should correspond to documentation keywords.

Each feature in Tiki has a wiki page which regroups all the bugs, requests for enhancements, etc. It is somewhat a form of wiki-based project management. You can also express your interest in a feature by adding it to your profile. You can also try out the Dynamic filter.

Accessibility (WAI & 508)
Accounting
Administration
Ajax
Articles & Submissions
Backlinks
Banner
Batch
BigBlueButton audio/video/chat/screensharing
Blog
Bookmark
Browser Compatibility
Calendar
Category
Chat
Comment
Communication Center
Consistency
Contacts Address book
Contact us
Content template
Contribution
Cookie
Copyright
Credits
Custom Home (and Group Home Page)
Database MySQL - MyISAM
Database MySQL - InnoDB
Date and Time
Debugger Console
Directory (of hyperlinks)
Documentation link from Tiki to doc.tiki.org (Help System)
Docs
DogFood
Draw
Dynamic Content
Preferences
Dynamic Variable
External Authentication
FAQ
Featured links
Feeds (RSS)
File Gallery
Forum
Friendship Network (Community)
Group
Help
History
Hotword
HTML Page
i18n (Multilingual, l10n, Babelfish)
Image Gallery
Import-Export
Install
Integrator
Interoperability
Inter-User Messages
InterTiki
jQuery
Kaltura video management
Karma
Live Support
Logs (system & action)
Lost edit protection
Mail-in
Map
Menu
Meta Tag
Missing features
Visual Mapping
Mobile
Mods
Modules
MultiTiki
MyTiki
Newsletter
Notepad
OS independence (Non-Linux, Windows/IIS, Mac, BSD)
Organic Groups (Self-managed Teams)
Packages
Payment
PDF
Performance Speed / Load / Compression / Cache
Permission
Poll
Profiles
Quiz
Rating
Realname
Report
Revision Approval
Scheduler
Score
Search engine optimization (SEO)
Search
Security
Semantic links
Share
Shopping Cart
Shoutbox
Site Identity
Slideshow
Smarty Template
Social Networking
Spam protection (Anti-bot CATPCHA)
Spellcheck
Spreadsheet
Staging and Approval
Stats
Survey
Syntax Highlighter (Codemirror)
Tablesorter
Tags
Task
Tell a Friend, alert + Social Bookmarking
Terms and Conditions
Theme
TikiTests
Timesheet
Token Access
Toolbar (Quicktags)
Tours
Trackers
TRIM
User Administration
User Files
User Menu
Watch
Webmail and Groupmail
WebServices
Wiki History, page rename, etc
Wiki plugins extends basic syntax
Wiki syntax text area, parser, etc
Wiki structure (book and table of content)
Workspace and perspectives
WYSIWTSN
WYSIWYCA
WYSIWYG
XMLRPC
XMPP




Useful Tools