Loading...
 

Category: WYSIWYG (What You See is What You Get)

WYSIWYG (What You See is What You Get)
Show subcategories objects

Name Type
Option: "Content is parsed like wiki page" leads to unwanted problems
tracker item
Plugin dialog is hidden when full-screen is on
tracker item
Plugin Edit removes line breaks in FancyTable
Using Plugin Edit to amend a FancyTable in WYSIWYG submitting a change causes all line breaks in the table body to be removed.

The PluginEdit shows the field "Rows separated by >> in the header; for the table body, one row per line. Cells separated by | in both cases."

Creating a working FancyTable with table body rows like this:

row 1 cell 1 | row 1 cell 2
row 2 cell 2 | row 2 cell 2

after inserting with the plugin edit tool this changes to:

row 1 cell 1 | row 1 cell 2 row 2 cell 2 | row 2 cell 2
tracker item
Plugin Gallerific Displays Incorrectly
tracker item
PluginMouseover data in WYSIWYG : line breaks are lost from the mouseover data
tracker item
WYSIWYG plugin fails to open if no parameter for page (regression from version 17)
tracker item
PluginWysiwyg doesn't open for edition in production site after upgrade to 18.x
tracker item
POST request to tiki-autosave-save breaks typing text leading to lost characters in Wysiwyg
tracker item
Quicktags simplebox assign from single caret to double to allow for more elements inside
The tiki normal editor has a problem when a page uses multiple carat elements. It creates unwanted boxes. i.e ~np~10^¹¹~/np~ used twice would create a malformed simplebox breaking the natural math operators into unreadable divisions.

The {img src=images/code.png}%%% {CODE()} ~np~ … ~/np~ {CODE} is not a workaround as this creates an unwanted space after the carat and before the next character. It is also awkward. It also does not allow the natural use of an otherwise perfectly suited math symbol.




tracker item
Random Poll with {poll} in user module not working
When i try to add{CODE(wrap="0",ishtml="0",ln="0",wiki="0",rtl="0",cpy="0")} {poll}{CODE} without id= to a user module in order to display random active polls (which i have previously created, activated and checked countless times) i get the following error when i edit the user module again. Using ckeditor, the sourcecode still shows {CODE(wrap="0",ishtml="0",ln="0",wiki="0",rtl="0",cpy="0")}{poll}. {poll id=n} {CODE}is working as it should.
{CODE(wrap="0",ishtml="0",ln="0",wiki="0",rtl="0",cpy="0")}
PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


http://tiki.org"(external link) />

FehlerFehler


missing poll ID for plugin POLL


Close Window

{CODE}
// Removed some empty lines from the code view
tracker item
Renaming or creation of pages with brackets in name not updating links when Wysiwyg
Renaming or creation of pages with brackets in name not updating links when Wysiwyg.

Affects both ? and normal links.
tracker item
Saving in WYSIWIG removes Edit Section buttons; saving in Wiki restores them; Wiki edit option disappears when doing a section edit
If you save a page in WYSIWYG, Edit Section buttons disappear. (However, if just before saving, you Switch Editor to wiki, the Edit Section buttons will (re-)appear (:wink:))

Note also separate bug #3764, i.e. the Switch Editor button does not appear if your edit is invoked by a Edit Section button. This makes the first bug very discouraging for new contributors.

This bug is a big issue for sites wishing to encourage collaborative editing, especially with longer pages:
*Having Edit Section buttons at each heading cries out 'Edit me! Edit me!'. If they disappear, it is much scarier for a beginner to edit a page.
*If someone bravely uses an Edit Section button only to find that it has disappeared as a result of their work, they may think they no longer have edit rights. They will think the site is stupid, and be greatly discouraged re further editing.
tracker item
The second editor of a page in wysiwyg mode will see an empty editor bloc when overriding
tracker item
Special Characters with tilde ~ don't seem to work
Wiki Syntax for special characters seems to fail in 1.10 (I can get it in WYSIWYG). Thus, ~np~~169~~/np~ no longer shows the copyright symbol.

The problem appears to lie in TikiLib - parse_data
if (!$simple_wiki and $prefs['feature_wysiwyg'] == 'n') {
$this->parse_htmlchar($data);

Here's this issue - I have WYSIWYG set to Y, but NOT showing by default. It seems that the test should be whether WYSIWYG is actually showing - I have no idea what the variable is.
tracker item
Structure TOC Plugin breaks CKEditor
tracker item
Switch from WYSIWYG to normal (wiki) editor error
When switching from normal (wiki) editor to WYSIWYG editor everything works fine. But when switching back from WYSIWYG to normal (wiki) editor, this actions simply times out, and IE or Opera are timing out.

This problem appears in 4.0 which was working fine in the 3.x version.
tracker item
Switching between 'normal' and WYSIWYG loses edits.
Doing edits in the WYSIWYG editor & switching to 'normal' loses the edits. The remaining content is presented as HTML source. Workaround: turn off option to use either 'normal' or WYSIWYG editor?
tracker item
Table Builder tool always inserts a table with a single row in WYSIWYG-wiki mode
tracker item
Text area field width and height parameters are not applied when using wysiwyg
tracker item
Text Disappearing in WYSIWYG
tracker item
The field with the smilies does not appear in places where they should be available
In certain instances when editing a page through the text editor (or creating a new blog post), with the wysiwyg-available available (though hidden) the smilies field is not displayed.

The problem is probably due to the fact that the variable $wysiwyg contains an 'n' if the editor is hidden while in some instances the value is NULL. This is probably because if the wysiwyg feature in admin-features is disabled then the $wysiwyg value is NULL, but if it is enabled but hidden the value is 'n'.

There is a conditional in templates/tiki-editpage.tpl that does not take this into account.

(The problem may be present in other versions as well)
tracker item
Tiki 6.2 : CKEditor translates all my wiki pages (containing HTML) to wiki syntax ???
Hi guys,

Yesterday, with tiki 6.1, i had a page witch source (partial) was like this :
------------
{HTML( wiki="0")}<h1 style="text-align:center;font-family:arial;font-size:26px;">Le Bureau de Windows</h1>{HTML}
{img fileId="50" thumb="y" rel="box[g]" align="center" desc="desc" alt="Exemple de bureau Windows" class="reflect"}
{HTML( wiki="0")}<div style="text-align:justify;font-family:arial;font-size:16px;line-height:20px;font-style:italic;">Le <b>bureau</b> de Windows est l'équivalent de notre bon vieux bureau ou table de travail.<br />Après le démarrage du système, c'est ce que nous avons en permanence sous les yeux et on y revient chaque fois que l'on quitte un programme.<br />De même que la table de travail d'un architecte ne ressemble en rien à celle d'un écrivain, chacun de nous a la liberté d'organiser et d'utiliser son bureau comme il le souhaite.</div>{HTML}
{HTML( wiki="0")}<h2 style="text-align:left;font-family:arial;font-size:22px;">Que mettre sur le Bureau ?</h2>{HTML}
{HTML( wiki="0")}<div style="text-align:justify;font-family:arial;font-size:16px;line-height:20px;">Il est pratique d'avoir sur le bureau des <b>raccourcis</b> vers nos programmes habituels comme navigateur Internet, messagerie, jeux, etc.<br />La <b>corbeille</b> y a aussi sa place bien entendu.<br />On peut également y installer des <b>raccourcis vers des fichiers</b> de tous types (photos, vidéos, documents...) ; En double-cliquant sur ce type de raccourci, Windows lance le programme approprié (associé à ce type de fichier).<br />On peut aussi déposer sur le bureau des notes en forme de 'post-it'<br />On trouve également aussi un raccourci vers le <b>Poste de travail</b> (appelé aussi Ordinateur) pour accéder aux données de notre machine (disques, clés USB, CD ou DVD...)</div>{HTML}
{img fileId="51" thumb="y" rel="box[g]" align="center" desc="desc" alt="Exemple de bureau avec des raccourcis" class="reflect"}
------------------
Today, with Tiki 6.2, if i want to edit this page in wysiwyg editor the source is :
------------------
<p>
{HTML( wiki="0")}&lt;h1 style=&quot;text-align:center;font-family:arial;font-size:26px;&quot;&gt;Le Bureau de Windows&lt;/h1&gt;{HTML}</p>
{img fileId="50" thumb="y" rel="box[g]" align="center" desc="desc" alt="Exemple de bureau Windows" class="reflect"}
<p>
{HTML( wiki="0")}&lt;div style=&quot;text-align:justify;font-family:arial;font-size:16px;line-height:20px;font-style:italic;&quot;&gt;Le &lt;b&gt;bureau&lt;/b&gt; de Windows est l'&eacute;quivalent de notre bon vieux bureau ou table de travail.&lt;br /&gt;Apr&egrave;s le d&eacute;marrage du syst&egrave;me, c'est ce que nous avons en permanence sous les yeux et on y revient chaque fois que l'on quitte un programme.&lt;br /&gt;De m&ecirc;me que la table de travail d'un architecte ne ressemble en rien &agrave; celle d'un &eacute;crivain, chacun de nous a la libert&eacute; d'organiser et d'utiliser son bureau comme il le souhaite.&lt;/div&gt;{HTML} {HTML( wiki="0")}&lt;h2 style=&quot;text-align:left;font-family:arial;font-size:22px;&quot;&gt;Que mettre sur le Bureau ?&lt;/h2&gt;{HTML} {HTML( wiki="0")}&lt;div style=&quot;text-align:justify;font-family:arial;font-size:16px;line-height:20px;&quot;&gt;Il est pratique d'avoir sur le bureau des &lt;b&gt;raccourcis&lt;/b&gt; vers nos programmes habituels comme navigateur Internet, messagerie, jeux, etc.&lt;br /&gt;La &lt;b&gt;corbeille&lt;/b&gt; y a aussi sa place bien entendu.&lt;br /&gt;On peut &eacute;galement y installer des &lt;b&gt;raccourcis vers des fichiers&lt;/b&gt; de tous types (photos, vid&eacute;os, documents...) ; En double-cliquant sur ce type de raccourci, Windows lance le programme appropri&eacute; (associ&eacute; &agrave; ce type de fichier).&lt;br /&gt;On peut aussi d&eacute;poser sur le bureau des notes en forme de 'post-it'&lt;br /&gt;On trouve &eacute;galement aussi un raccourci vers le &lt;b&gt;Poste de travail&lt;/b&gt; (appel&eacute; aussi Ordinateur) pour acc&eacute;der aux donn&eacute;es de notre machine (disques, cl&eacute;s USB, CD ou DVD...)&lt;/div&gt;{HTML}<span> </span></p>
{img fileId="51" thumb="y" rel="box[g]" align="center" desc="desc" alt="Exemple de bureau avec des raccourcis" class="reflect"}
------------------------
But, if i use by section editing, i recover my code like this :
------------------------ partial sample
<div style="text-align:justify;font-family:arial;font-size:16px;line-height:20px;font-style:italic;">Le <b>bureau</b> de Windows est l'équivalent de notre bon vieux bureau ou table de travail.<br />Après le démarrage du système, c'est ce que nous avons en permanence sous les yeux et on y revient chaque fois que l'on quitte un programme.<br />De même que la table de travail d'un architecte ne ressemble en rien à celle d'un écrivain, chacun de nous a la liberté d'organiser et d'utiliser son bureau comme il le souhaite.</div>
------------------------

What's the matter ?

Thanks

Jean-Luc NAVARRO.
tracker item
Tiki 7.1 HTML parsing - WYSIWYG/CKE - not working in some feature like for ex. in articles
Hello Devs,

I did upgrade a site to 7.1 this weekend.

Using WYSIWYG/CKE I have the following prblem:

In some features of the Tiki 7.1 the output the editor is just the plain
HTML Source.

That means, not in Wikipages, but in the articles and in the calendar
events, there is not a nice text with formatting bold, italic, colors
and pictures etc, but only the plain HTML source code visible to the
website user/visitor.

The WYSIWYG/CKE editor works normal and I can see the content just
normal like ever, being in the editing mode. But when I save, I can just
see the source code, like it would be in codeplugin.

This affects as said articles and calendar (perhabs more, I will hope to
find out) but it does not affect wikipages by now.

And it affects existing articles and events aswell as newly edited.

(worked well in 6.x before)

Thx for reply and wish a nice sunday to all,
cheers
Torsten
tracker item
Tiki Plugin with long content broke wysiwyg edit display
tracker item
Toolbar setting are not saved
tracker item
Toolbar wysiwyg is not working in tracker for text area set to multilingual
tracker item
Unable to align images with links on a single line in Tiki 14.2
tracker item
Unwanted alert "You are about to leave this page" when using wysiwyg in trackers
tracker item
Upload and Reference File/Image Resources in one Step
Hi there,

it is very unhandy to attach files or include images in wiki pages, articles or any other content a user provides. Until now, there are means like:

a) Upload a file to a file gallery and reference it manually using the link given.
b) Upload a file to a wiki page and reference it manually.
c) Try using the WYSIWYG editor and realize it does not upload the image.

Well, what I did is I added some quicktags to your code that opens a custom upload file dialog with a preselected file gallery. The user can browse, upload and add the file into his content in one step. Basically it uploads the file and appends the wiki code at the cursor position.

I will attach you all my environment...there is a file itb_readme.txt in the root which describes in chapter 3 all the changes I do...maybe somebody of your development team assesses this as an important feature and can leverage some code...

Regards,

Maic
tracker item
Using IE8 to open plugin editor in the WYSIWYG edit screen causes errors
tracker item
Using PluginWYSIWYG for an image which has been drawn on: It goes awry
tracker item
Version 6 WYSIWYG background with Darkshine theme
WYSIWYG editor is displaying theme background inside of edit box using darkshine. This results in the red and red stripe background behind your editing, but this background does not appear behind the wiki page when viewed (displayed on white, as is desired)
tracker item
very minor problem with SORT plugin when used with wysiwyg editor
tracker item
Wanted page links not changing after page is created when wysiwyg is in use
Create a page using the wysiwyg editor and make some page links.

Then create the page from one of these wanted links.

The wanted links are not converted back to normal wiki links (still look like wanted links)
tracker item
Wanted: default class for images added in wiki editors
Images that are added using the wiki editor (anyway the normal editor, I didn't check the wysiwyg editor yet) don't have a default class. This is the simple case of no containing box or anything added along with the image. Therefore it isn't possible for them to have a default style such as margin or border unless it is added manually by the page author. Or if it is specified by the stylesheet (.postbody img or .wikitext img, etc.) then ''all'' images in those divs get the treatment, including smileys and external link icons, etc.

I suggest adding a default class like "contentimage" to enable a default style. Page authors can always add a second class if needed.
tracker item
What you see in WYSIWYG HTML editor is NOT NECESSARILY what you get
tracker item
What you see in WYSIWYG editor with Tiki markup is NOT NECESSARILY what you get
tracker item
Text box and other formatting disappear when switching from WYSIWYG to non-WYSIWYG
tracker item
Wiki links when using wysiwyg don't survive rename
Renaming a page does not change links in pages created using the wysiwyg editor
tracker item
Wiki page picker (WYSIWYCA) in edit mode, plugin help and anywhere relevant
In edit mode, if I do

{CODE()}
((
{CODE}


(and maybe a few letters), an auto-complete should appear, like the quick_edit module. This list should be WYSIWYCA.


This would also be useful in some plugins, when a parameter is wiki=

The most important is ((doc:PluginInclude)), because the main goal of the plugin is to include other pages, which you may not know the exact name.

When in plugin edit mode, an auto-complete could be done with jQuery (ask LPH for details)

Related:
{wish id=480}

tracker item
Wiki-links and non-latin characters
__problem __with Russian (and, as I understood, any non-English character language) wiki-links in CKE Editor (and plugins):
1. Let's create wiki page named "Фичи" (copy-paste, hope it'll be work)
2. Create page with any name e.g. test with wiki-link to a first page ("Фичи").
3. Link is broken. becouse on the stage of convertation from wiki-link to CKE URL something goes wrong and if You click on this link and choose "Edit Link" you'll see "tiki-index.php?page=Фичи"
3.1 Yes, link is broken:
Page not found
äøÃÂø
----
Hint: without WYSIWYG editor all will be ok. No broken links with any symbols.

__Why priority is high?__
-becouse we can't create ANY wiki-links from CKE-editor if wiki page named with non-Latin leters.

p.s.
double-checked here http://php.opensourcecms.com/scripts/details.php?scriptid=63
with WYSIWYG_6x profile.

tags: utf-8, russian, link, wiki
tracker item
Wrong link encoding in Wysiwyg editor
When I create a link to a Wiki page, the editor changes the reference of the link until the fourth time when I edit the page, but this is not a problem. The problem occurs when the link points to a wiki that has a special character, for example - cabeçalho - which means header (in Portuguese from Brazil), since the editor corrupts the link and it crashes.

Here I have an example.

The link should point to the wiki - Projeto de Pesquisa Social: Quem somos nós ? Proeja 2010 - is corrupted by the editor and points for - Projeto+Pesquisa+Social:+Quem+somos+n%C3%83%C3%83%C3%83%C3%83%C3%83%C3%82%C2%B3s?+Proeja+2010 -


Here we have a wiki page as an example:
http://www.biblioteca.ifc-camboriu.edu.br/criacitec/tiki-index.php?page=Example
tracker item
Wysiwig FCKEditor on test : the background of long text area when vertical scroll is black - Firefo
This seems solved in Tiki 5.

''type content'' : Problem, way to go around and may be a quick way to go to a solution

Hy,
4.0, 4.1

I test all functions including those that are not finalized.

The problems occurs with Firefox 3.5 not with IE8 (other ie not tested neither opera, google etc...)

In WISIWIG text editing WIKI obtained in circumstances that I can not confirm the background color of textarea is black when you scroll to the end of long text (the text is more long than the height of textarea).
The content text exist and you can see it if you select it and change the text background color.
The problem is the scroll with the background property color (in strasa css #F3FCFE color)

''Complements''
*Problems occurs in wysiwyg mode (not in view source mode)
*If you change the background color of the text you can see it
*The problem is directly linked to scroll, when you change the textarea size (for example go to "fullscreen" edit), the black background appears at the bottom just one line after beginning to scroll down



I hope to have provided informations to go straight to the bug.

Best regards
tracker item
WYSIWYG - "Insert internal wiki link" button doesn't work (infinite wait)
I have a strange problem on Tiki 2.0RC2:

I have two similar TikiWiki-installations. One just for testing on my Linux-Server and the second on a WinNT-Server. The Windows-Server is the one we want to/have to use for our Wiki :-(

On my Linux-Server works everything.

On the Win-Server don’t work wysiwyg-editor’s “Insert/Edit an internal wiki link”-button. The “window” opens but it shows only this animated waiting-bar. (See the picture)
Any other button works fine!
tracker item
WYSIWYG Acting Strange
tracker item
WYSIWYG admin - Option to set default image upload directory
On the admin page for the WYSIWYG editor it would be handy to have a text box available to set the default upload directory used by fckEditor so that we could select (and enforce) a suitable location on the server (such as C:\TikiWiki\img).
tracker item
WYSIWYG admin panel should appear when basic prefs is chosen (the default)
tracker item
WYSIWYG and International character problem in links
Problem: Corrupted URLs when linking pages using international characters in the page name.
It works when the link is first saved, but a reload and a subsequent saved will corrupt the URL.
The same problem occurs in 6.x 7.x and 8.0 SVN.

In these tests the WYSIWYG editor is used.
(I have formatted the output a little for better readability)

--- Test using latest 8.0 SVN version ---

1. Create the page "ÆØÅ page"
2. Create the page "MyLinkPage"
3. Add a link to "ÆØÅ page" on MyLinkPage, using the link tool in the menu
4. Save and exit editor

Content of MyLinkPage (wiki source view)
<p><a class="wiki" href="tiki-index.php?page=%C6%D8%C5+page">ÆØÅ page</a></p>

Content of MyLinkPage in the database (tiki_pages.data)
'<p><a class="wiki" href="tiki-index.php?page=%C6%D8%C5+page">ÆØÅ page</a></p>'

5. Edit MyLinkPage again <<<<<<<<<<<<< URL is no longer encoded, but the page name is

Content of MyLinkPage (WYSIWYG source view)
<p><a class="wiki" href="tiki-index.php?page=ÆØÅ+page">&AElig;&Oslash;&Aring; page</a></p>

6. Add some text in the WYSIWYG editor
added some text

8. Save and exit editor <<<<<<<<<<<<<<<< CONTENT HAS A CORRUPTED URL

Content of MyLinkPage (wiki source view)
<p><a class="wiki" href="tiki-index.php?page=%C3%86%C3%98%C3%85+page">ÆØÅ page</a></p>
<p>added some text</p>

Content of MyLinkPage in the database (tiki_pages.data)
'<p><a class="wiki" href="tiki-index.php?page=%C3%86%C3%98%C3%85+page">ÆØÅ page</a></p>
<p>added some text</p>
'

---- end of test ----

As far as I can see, the problem occurs when the WYSIWYG editor loads the page
(it works the first time, because the links are not loaded, only saved).

I tried a similar test using the wiki editor
The wiki editor stores the wiki content.
Thus database the content is: ((ÆØÅ page|ÆØÅ page))
The wiki editor has no problems.

A variation is loading the page using the wiki editor, then switching to the WYSIWYG editor
The source in WYSIWYG is afterwards

<p><a class="wiki" href="tiki-index.php?page=Ã?Ã?Ã?+page" title="ÆØÅ page">&AElig;&Oslash;&Aring; page</a><br />
added some text</p>

thus also corrupted the URL.
tracker item
WYSIWYG and normal editor are not screen width in IE8
This bug is seen by our IE 8 clients. We are running Tiki 6.2 (clean install), on a Windows 2003 Server, Apache 2.2.16 w SSL, PHP 5.3.3, remote MySQL 5 database.

When our users try to edit their pages either in WYSIWYG or normal mode, their editor text box is half the width that it should be. They need to use the dragger to make it wider. If we edit in Firefox then the editor is the correct width.

Since IE is our corp standard our users need to be able to add files using that browser. Also, this is the same problem we had in Tiki 5.x and we were hoping 6.x would have fixed it.

Thanks,
Tim
tracker item
Wysiwyg doesn't allow using ! (headings) or * or # (lists) markup in mixed mode yet
Right now using 1.10svn code when using wysiwyg you are not allowed to use ! (headings) and * or # (lists) as wiki markup (it gets shown as simple text, even if placed at the beggning of new lines)

According to http://doc.tikiwiki.org/Wysiwyg+Editor+Admin (April 10th, 2008) , the setting "__Content is partially parsed__" just includes:
* parsing of links
* parsing of images and generally what is included in { }
* parsing of wikiplugins

Header and butllets are vey simple and common wiki markup that would help mixing conent in wysiwyg pages from newbies on tiki 1.10 sites and more experienced users (not much skills needed for that markup)
tracker item
WYSIWYG HTML editor "help" assumes wysiwyg_wiki_parsed is enabled
tracker item
WYSIWYG editor addes extra <br> tags
When you edit text using the WYSIWYG editor, extra <br /> tags are added when the text is displayed in preview or when it is saved. These break tags do not show up when you try to edit the page again, making them impossible to remove.

For example, if the markup in the WYSIWYG editor, when you view the source, is as follows:

''<p>This is some text.<br />This is some more text, on a new line</p>''

What shows up when you view the source of the page that is generated after you save/preview is as follows:

''<p>This is some text.<br /><br />This is some more text, on a new line</p><br />''

As a result of this, the spacing on pages edited by the WYSIWYG editor is bizarre and stretched out.

tracker item
WYSIWYG editor addes extra <br> tags
When one is using the WYSIWYG editor to edit text, extra <br /> tags are added after all <p> and <br /> tags when the text is displayed after save or preview. These tags don't show up in the source code in the WYSIWYG editor at all, so you can't remove them. As a result, the spacing between the text is all wrong.

For example, if you view the source of a page in the WYSIWYG editor, it would look like this:

<p>Some text<br />And more text on a new line</p>

But when you view the source of the page after you have saved it, it looks like this:

<p>Some text<br /><br />And more text on a new line</p><br />

tracker item
Wysiwyg editor doesn't load the plugin helpers
tracker item
#2037
Bugs & Wish list
tracker item
WYSIWYG Editor Transparent background Issue
The WYSIWYG editor has a transparent background that seems to be hard-coded and unaddressable by css. It appears in an iFrame so the page's body background colour is seen in the textarea.

This makes it unusable for themes with dark backgrounds like Strasa as you have basically black-on black text.
tracker item
wysiwyg editor, or normal editor with html enabled, doesn't parse {maketoc} on wiki pages
See live example here:
http://moviments.net/cursos/IMDIG-I-Apunts

Wysiwyg editor is enabled, and those are the general wysiwyg settings on the site:
|| Wysiwyg Editor is optional: | X
... and is displayed by default: |
Reopen with the same editor: | X
Content is parsed like wiki page: | X
Content is partially parsed: | X ||

The wiki page http://moviments.net/cursos/IMDIG-I-Apunts was last edited using normal editor, keeping "allow html" checkbox as enabled on that page. When you write
{CODE()}
{maketoc}
{CODE}

The string ~np~{maketoc}~/np~ is displayed, but the table of contents fort that page.
tracker item
WYSIWYG File gallery can't deal with non image files
tracker item
Wysiwyg help needs updating
tracker item
WYSIWYG Icons Missing in Kama Theme in Firefox
tracker item
Wysiwyg Image Plugin Editor in IE7 erases image on insert
Only happens in real IE7. IE8 in IE7 compatibility mode does not have this problem.

Basically an attempt to edit the image plugin parameters followed by clicking on "Insert" results in a JS error "Invalid argument" at line 4929 of lib/jquery/jquery.js (r30367). If you continue through the error, the image disappears.

{CODE()}
clean: ....
.....
if ( fragment ) {
.......
if ( ret[i].nodeType === 1 ) {
ret.splice.apply( ret, [i + 1, 0].concat(jQuery.makeArray(ret[i].getElementsByTagName("script"))) );
}
fragment.appendChild( ret[i] ); // this is line 4929
{CODE}

If the image is at the end of a paragraph (or on a line of it's own) resulting in the following cases, you will have the problem.

{CODE()}
<p>
Paragraph text{img fileId="10" rel="box[g]" imalign="left"}</p>
{CODE}

{CODE()}
<p>
{img fileId="10" rel="box[g]" imalign="left"}</p>
{CODE}

If you instead have text after the image, the problem does not appear. For example, the following are both OK.

{CODE()}
<p>
Paragraph text{img fileId="10" rel="box[g]" imalign="left"}Paragraph Text</p>
{CODE}

{CODE()}
<p>
{img fileId="10" rel="box[g]" imalign="left"}Paragraph Text</p>
{CODE}

I suspect (just a theory) maybe the plugin replacing procedure is wiping out the closing para tag leading to malformed HTML that IE7 does not like. A search on the web on similar errors in relation to Jquery show that IE7 is very sensitive to unclosed tags or malformed HTML in inserted text.
tracker item
WYSIWYG in blogs is broken in BRANCH-1-9
[http://tikiwiki.org/tiki-view_blog_post.php?blogId=2&postId=249|See an exemple of result]


It was working fine in BRANCH-1-8
tracker item
WYSIWYG Insert internal link fails
ON aVersion 2.2 installation on a Windows server.

When I use the WYSIWYG editor and select the insert internal link icon, the window appears titled "Tiki Link - insert internal link" and the squares indicating loading are blinking, but it hangs (and does not bring up the list of links).
tracker item
WYSIWYG messes hashsign links in templates
tracker item
WYSIWYG Paragraphs
Paragraphs appear with an extra line of whitespace when laid out in the wysi editor.

The same page performs as expected for white space if you click edit, switch to wiki editor and save.

But then: Re-opening the same page (with wysi set as site default) shows everything on one line with just spaces where the linefeeds used to be.


Also just noticed: Editing post makes a new publication date--in advance of current date time.
tracker item
WYSIWYG SAVE button takes user to a blank page (tiki-editpage.php), and does not save content.
The topic says it all. I am running SLES Linux 10 for wiki host and with MySQL on a Netware box on the back end. MySQL Version 4.0.26a over TCP/IP.

I hope this helps.
tracker item
WYSIWYG Table builder, link buttons and others not working correctly.
tracker item
WYSIWYG table editor is broken (lf are converted into %%%)
tracker item
WYSIWYG testing: automated testing to edit and save, and check if anything was edited without user intervention
tracker item
WYSIWYG Toolbars
tracker item
WYSIWYG_6x - Anchor flag not saving
We are running Tiki 6.2 (clean install), on a Windows 2003 Server, Apache 2.2.16 w SSL, PHP 5.3.3, remote MySQL 5 database.

This bug is across all browsers.

Our users are editing in the CKEditor WYSIWYG and trying to add anchors. When using the WYSIWYG_6x default profile of:%%%{CODE()}Editing and Plugins
Wiki Paragraph formatting (ON, however default: off)
...but still create line breaks within paragraphs (on)
HTML Purifier (on)
Wiki
Allow HTML (on, however default: off)
WYSIWYG
Content is parsed like wiki page (on)
Content is partially wiki parsed (off)
Use Wiki syntax in WYSIWYG (off){CODE}%%%our users use the Anchor icon (flag) to create an anchor at the bottom of a page. The anchor name window comes up and they give it a name, save, a yellow anchor icon is displayed in the editor. If they jump to the top of the page and create a Link (using the Link icon in the toolbar) and select Link Type: "Link to another anchor in the text", Select an Anchor/By Anchor Name and press Ok. At this point everything looks correct in CKEditor.The user presses Save. The Link at the top is correct using the normal syntax %%% {CODE()}[#myAnchor|Link to bottom]{CODE}%%%however the anchor at the bottom is gone as if it never saved or the parser has discarded it.

I have had to instruct our users how to type in manually the anchors using the old plugins [http://doc.tiki.org/PluginAlink] and [http://doc.tiki.org/PluginAname]. They are not happy about using long hand plugin notation.

I have tried in both IE 8 and FF 3.6 with the same result.

Since IE is our corp standard our users need to be able to add anchors using that browser. Also, they had no problem in Tiki 5.x but that was a different WYSIWYG system.

May be related to [http://dev.tiki.org/tiki-view_tracker_item.php?itemId=1499]
tracker item
WYSIWYG_6x - Edit Section buttons return blank page
We are using Tiki v6.2 vanilla, PHP 5.3.3. When using the WYSIWYG_6x default profile of:%%%{CODE()}Editing and Plugins
Wiki Paragraph formatting (ON, however default: off)
...but still create line breaks within paragraphs (on)
HTML Purifier (on)
Wiki
Allow HTML (on, however default: off)
WYSIWYG
Content is parsed like wiki page (on)
Content is partially wiki parsed (off)
Use Wiki syntax in WYSIWYG (off){CODE}%%%we can not edit a section using the Edit Section button. A blank WYSIWYG screen is displayed and if you enter content and save it gets thrown to the bottom of the wiki page and not within the section.

Reproduce: Create a blank wiki page in WYSIWYG, create a bunch of headers, save, view edit icons (if not already), click on "Edit Section" button.
tracker item
WYSIWYG_6x - Formatting breaks "header" status
We are using Tiki v6.2 vanilla, PHP 5.3.3. When using the WYSIWYG_6x default profile of:%%%{CODE()}Editing and Plugins
Wiki Paragraph formatting (ON, however default: off)
...but still create line breaks within paragraphs (on)
HTML Purifier (on)
Wiki
Allow HTML (on, however default: off)
WYSIWYG
Content is parsed like wiki page (on)
Content is partially wiki parsed (off)
Use Wiki syntax in WYSIWYG (off){CODE}%%%we can not format the header (color it red) without breaking the "header" status.

Currently we have a page with a ~np~{maketoc}~/np~ at the top and a bunch of h1, h2, h3 headers. We wanted to make the text color red for one of the h1 titles so it was more visible to users. Once we did this in the WYSIWYG editor, the header is no longer listed in the maketoc AND the Edit Section button is gone next to the header text. This ''may'' be associated with another bug [http://dev.tiki.org/tiki-view_tracker_item.php?itemId=3763].

tracker item
WYSIWYG_6x - List spacing inconsistent
We are using Tiki v6.2 vanilla, PHP 5.3.3. When using the WYSIWYG_6x default profile of:%%%{CODE()}Editing and Plugins
Wiki Paragraph formatting (ON, however default: off)
...but still create line breaks within paragraphs (on)
HTML Purifier (on)
Wiki
Allow HTML (on, however default: off)
WYSIWYG
Content is parsed like wiki page (on)
Content is partially wiki parsed (off)
Use Wiki syntax in WYSIWYG (off){CODE}%%% the lists (numbered and unordered) have irregular spacing between lines. Edited in Wiki normal and WYSIWYG Source modes work fine.

To reproduce create the following structure in a WYSIWYG editor{CODE()}*blah zaa zaa
*This is a list
**now indenting the list
**blah
*back out
**back in
***really far in
*all the way out{CODE} %%% this example displays for us as {CODE()} blah zaa zaa

This is a list

now indenting the list
blah

back out

back in

really far in
all the way out
{CODE} %%% Sometimes there is a break, other times there is not. If I Preview while editing it looks fine. If I edit the HTML via the Source WYSIWYG view and save then it looks fine until I save it in WYSIWYG mode again.
tracker item
WYSIWYG_6x inserts !'s into text before any text formatted as a header, saved, then edited again
When editing or creating a page using the WYSIWYG_6x editor, setting any text as a header then saving the file works correctly, however if the page is edited again, the WYSIWYG editor inserts a ! before or sometimes after the text you decided to format as a header.

Looking at the source, it appears that it is inserting the following into the page:

<p>
!</p>

Attempting to remove it by deleting the ! in the WYSIWYG editor just results in it showing up again, either immediately after saving or on the next edit of the page. This results in people not wanting to use the header feature or finding other workarounds such as larger font size.
tracker item
WYSIWYG-editing a WYSIWYG plugin call adds a trailing newline
tracker item
WYSIWYG-editing a WYSIWYG plugin call may remove newlines
tracker item
WYSIWYG: preview and WYSIWYG is quite different for second level bullet
tracker item
WYSIWYG: With Firefox, some tools don't show Karma CKeditor theme
tracker item
  • 1
  • 2 (current)
  • »

Keywords

The following is a list of keywords that should serve as hubs for navigation within the Tiki development and should correspond to documentation keywords.

Each feature in Tiki has a wiki page which regroups all the bugs, requests for enhancements, etc. It is somewhat a form of wiki-based project management. You can also express your interest in a feature by adding it to your profile. You can also try out the Dynamic filter.

Accessibility (WAI & 508)
Accounting
Administration
Ajax
Articles & Submissions
Backlinks
Banner
Batch
BigBlueButton audio/video/chat/screensharing
Blog
Bookmark
Browser Compatibility
Calendar
Category
Chat
Comment
Communication Center
Consistency
Contacts Address book
Contact us
Content template
Contribution
Cookie
Copyright
Credits
Custom Home (and Group Home Page)
Database MySQL - MyISAM
Database MySQL - InnoDB
Date and Time
Debugger Console
Directory (of hyperlinks)
Documentation link from Tiki to doc.tiki.org (Help System)
Docs
DogFood
Draw
Dynamic Content
Preferences
Dynamic Variable
External Authentication
FAQ
Featured links
Feeds (RSS)
File Gallery
Forum
Friendship Network (Community)
Group
Help
History
Hotword
HTML Page
i18n (Multilingual, l10n, Babelfish)
Image Gallery
Import-Export
Install
Integrator
Interoperability
Inter-User Messages
InterTiki
jQuery
Kaltura video management
Karma
Live Support
Logs (system & action)
Lost edit protection
Mail-in
Map
Menu
Meta Tag
Missing features
Visual Mapping
Mobile
Mods
Modules
MultiTiki
MyTiki
Newsletter
Notepad
OS independence (Non-Linux, Windows/IIS, Mac, BSD)
Organic Groups (Self-managed Teams)
Packages
Payment
PDF
Performance Speed / Load / Compression / Cache
Permission
Poll
Profiles
Quiz
Rating
Realname
Report
Revision Approval
Scheduler
Score
Search engine optimization (SEO)
Search
Security
Semantic links
Share
Shopping Cart
Shoutbox
Site Identity
Slideshow
Smarty Template
Social Networking
Spam protection (Anti-bot CATPCHA)
Spellcheck
Spreadsheet
Staging and Approval
Stats
Survey
Syntax Highlighter (Codemirror)
Tablesorter
Tags
Task
Tell a Friend, alert + Social Bookmarking
Terms and Conditions
Theme
TikiTests
Timesheet
Token Access
Toolbar (Quicktags)
Tours
Trackers
TRIM
User Administration
User Files
User Menu
Watch
Webmail and Groupmail
WebServices
Wiki History, page rename, etc
Wiki plugins extends basic syntax
Wiki syntax text area, parser, etc
Wiki structure (book and table of content)
Workspace and perspectives
WYSIWTSN
WYSIWYCA
WYSIWYG
XMLRPC
XMPP




Useful Tools