This page is to document how/where to set minimum requirements in Tiki.

The following files need to be updated:

FileDescription
setup.shUpdate the constant REQUIRED_PHP_VERSION used in composer
doc/devtools/etc/update/software-versions-required.txtUpdate min and max values for PHP and Tiki versions
lib/core/Tiki/Package/ComposerCli.phpUpdate the value for PHP_MIN_VERSION constant
tiki-check.phpAdd or update different warning messages for different PHP versions, search for the usage of PHP_VERSION constant
tiki-install.phpUpdate the check that PHP version is sufficient
tiki-setup.phpUpdate warning messages and the check that PHP version is sufficient


Here are previous examples: